ログイン

19
6月

起動画面が真っ暗

Written by チキチキ. No comments Posted in: Linux
Tagged with
Posted Date : 2010-06-19

ClientPCのubuntuを9.10から10.04にアップグレードしたら
起動画面が真っ暗になった。
色々ググってPlymouthやG Alternativesで設定を変えても
何やらゴミが表示されるだけ。
起動はするけど起動中エラーが出たら何~んにも解んないので困った。
ググッてググってやっと見つけ出した答えは、こちらの方と同じ原因でした。
http://d.hatena.ne.jp/dayflower/20100521/1274430126

9.10で設定したプロプライエタリなnvidiaのドライバをそのままにして
10.04にアップグレードしたら仕様でスプラッシュの表示解像度が低くなって
表示できなくなったみたいです。
上記のURLを参考ににして、v86dのコンポーネントをインストールして、
グラフィックボードの解像度を調べる。

$ sudo aptitude install v86d
$ sudo hwinfo –framebuffer
02: None 00.0: 11001 VESA Framebuffer                           
[Created at bios.464]
Unique ID: rdCR.J_Jn8xLAly7
Hardware Class: framebuffer
Model: “NVIDIA G94 Board – 05620000”
Vendor: “NVIDIA Corporation”
Device: “G94 Board – 05620000”
SubVendor: “NVIDIA”
SubDevice:
Revision: “Chip Rev”
Memory Size: 14 MB
Memory Range: 0xf9000000-0xf9dfffff (rw)
Mode 0x0300: 640×400 (+640), 8 bits
Mode 0x0301: 640×480 (+640), 8 bits
Mode 0x0303: 800×600 (+800), 8 bits
Mode 0x0305: 1024×768 (+1024), 8 bits
Mode 0x0307: 1280×1024 (+1280), 8 bits
Mode 0x030e: 320×200 (+640), 16 bits
Mode 0x030f: 320×200 (+1280), 24 bits
Mode 0x0311: 640×480 (+1280), 16 bits
Mode 0x0312: 640×480 (+2560), 24 bits
Mode 0x0314: 800×600 (+1600), 16 bits
Mode 0x0315: 800×600 (+3200), 24 bits
Mode 0x0317: 1024×768 (+2048), 16 bits
Mode 0x0318: 1024×768 (+4096), 24 bits
Mode 0x031a: 1280×1024 (+2560), 16 bits
Mode 0x031b: 1280×1024 (+5120), 24 bits
Mode 0x0330: 320×200 (+320), 8 bits
Mode 0x0331: 320×400 (+320), 8 bits
Mode 0x0332: 320×400 (+640), 16 bits
Mode 0x0333: 320×400 (+1280), 24 bits
Mode 0x0334: 320×240 (+320), 8 bits
Mode 0x0335: 320×240 (+640), 16 bits
Mode 0x0336: 320×240 (+1280), 24 bits
Mode 0x033d: 640×400 (+1280), 16 bits
Mode 0x033e: 640×400 (+2560), 24 bits
Mode 0x0345: 1600×1200 (+1600), 8 bits
Mode 0x0346: 1600×1200 (+3200), 16 bits
Mode 0x0347: 1400×1050 (+1400), 8 bits
Mode 0x0348: 1400×1050 (+2800), 16 bits
Mode 0x0349: 1400×1050 (+5600), 24 bits
Mode 0x034a: 1600×1200 (+6400), 24 bits
Mode 0x0352: 2048×1536 (+8192), 24 bits
Mode 0x0360: 1280×800 (+1280), 8 bits
Mode 0x0361: 1280×800 (+5120), 24 bits
Mode 0x0362: 768×480 (+768), 8 bits
Mode 0x0364: 1440×900 (+1440), 8 bits
Mode 0x0365: 1440×900 (+5760), 24 bits
Mode 0x0368: 1680×1050 (+1680), 8 bits
Mode 0x0369: 1680×1050 (+6720), 24 bits
Mode 0x037b: 1280×720 (+5120), 24 bits
Mode 0x037c: 1920×1200 (+1920), 8 bits
Mode 0x037d: 1920×1200 (+7680), 24 bits
Config Status: cfg=new, avail=yes, need=no, active=unknown


ディスプレイは1680×1050なので/etc/default/grubを以下の様に書き換える。
GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash nomodeset (表示都合により改行)
   video=uvesafb:mode_option=1680×1050-24,mtrr=2,scroll=ywrap”

GRUB_GFXMODE=1680×1050
そして、カーネル起動時に uvesafb モジュールを読み込む為に
/etc/initramfs-tools/moduleに以下を追記。

uvesafb mode_option=1680×1050-24 mtrr=2 scroll=ywrap

次に、/etc/initramfs-tools/conf.d/splashファイルを作成して以下を追記する。
FRAMEBUFFER=y
最後にGRUB2とinitramfsを更新して再起動して確認。
$ sudo update-grub2
$ sudo update-initramfs -u

やっと出た~!!!
dayflower様、感謝感謝です。

Similar Posts:


[Print here click]

0 Responses


Protected Image